]> git.pld-linux.org Git - packages/libsigc++3.git/blob - libsigc++3.spec
- updated to 3.0.4
[packages/libsigc++3.git] / libsigc++3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  tests           # check target
5 #
6 Summary:        The Typesafe Signal Framework for C++
7 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
8 Name:           libsigc++3
9 Version:        3.0.4
10 Release:        1
11 Epoch:          1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/3.0/libsigc++-%{version}.tar.xz
15 # Source0-md5:  63889b161cf61570dd704568a879882d
16 URL:            https://libsigcplusplus.github.io/libsigcplusplus/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  doxygen >= 1:1.8.9
20 BuildRequires:  libstdc++-devel >= 6:7
21 BuildRequires:  libtool >= 2:2.0
22 BuildRequires:  m4
23 BuildRequires:  mm-common >= 0.9.12
24 BuildRequires:  perl-base
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Obsoletes:      libsigc++-examples
29 Conflicts:      libsigc++ < 1.1.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This library implements a full callback system for use in widget
34 libraries, abstract interfaces, and general programming. Originally
35 part of the Gtk-- widget set, libsigc++ is now a seperate library to
36 provide for more general use. It is the most complete library of its
37 kind with the ablity to connect an abstract callback to a class
38 method, function, or function object. It contains adaptor classes for
39 connection of dissimilar callbacks and has an ease of use unmatched by
40 other C++ callback libraries.
41
42 %description -l pl.UTF-8
43 Ta biblioteka jest implementacją pełnego systemu callbacków do
44 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
45 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
46 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
47 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
48 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
49 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
50 callbacków.
51
52 %package devel
53 Summary:        Development tools for the Typesafe Signal Framework for C++
54 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
55 Group:          Development/Libraries
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57 Requires:       libstdc++-devel >= 6:7
58 Requires:       m4
59
60 %description devel
61 Development tools for the Typesafe Signal Framework for C++.
62
63 %description devel -l pl.UTF-8
64 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
65 kontrolą typów.
66
67 %package static
68 Summary:        Static Typesafe Signal Framework for C++ libraries
69 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static Typesafe Signal Framework for C++ libraries.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
78
79 %package doc
80 Summary:        Reference documentation for libsigc++
81 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
82 Group:          Documentation
83
84 %description doc
85 Reference documentation for libsigc++.
86
87 %description doc -l pl.UTF-8
88 Szczegółowa dokumentacja dla libsigc++.
89
90 %prep
91 %setup -q -n libsigc++-%{version}
92
93 %build
94 mm-common-prepare --copy --force
95 %{__libtoolize}
96 %{__aclocal} -I build
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --disable-silent-rules \
102         %{?with_static_libs:--enable-static}
103 %{__make}
104
105 %if %{with tests}
106 %{__make} check
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # obsoleted by pkg-config
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsigc-3.0.la
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README.md
127 %attr(755,root,root) %{_libdir}/libsigc-3.0.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libsigc-3.0.so.0
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libsigc-3.0.so
133 %{_includedir}/sigc++-3.0
134 %{_libdir}/sigc++-3.0
135 %{_pkgconfigdir}/sigc++-3.0.pc
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libsigc-3.0.a
141 %endif
142
143 %files doc
144 %defattr(644,root,root,755)
145 %{_datadir}/devhelp/books/libsigc++-3.0
146 %{_docdir}/libsigc++-3.0
This page took 0.089689 seconds and 3 git commands to generate.